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A Complete Stata Documentation Set contains more than 12,000 pages of information in the following
manuals:
[GSM] Getting Started with Stata for Mac
[GSU] Getting Started with Stata for Unix
[GSW] Getting Started with Stata for Windows
[U] Stata User’s Guide
[R] Stata Base Reference Manual
[BAYES] Stata Bayesian Analysis Reference Manual
[D] Stata Data Management Reference Manual
[FN] Stata Functions Reference Manual
[G] Stata Graphics Reference Manual
[IRT] Stata Item Response Theory Reference Manual
[XT] Stata Longitudinal-Data/Panel-Data Reference Manual
[ME] Stata Multilevel Mixed-Effects Reference Manual
[MI] Stata Multiple-Imputation Reference Manual
[MV] Stata Multivariate Statistics Reference Manual
[PSS] Stata Power and Sample-Size Reference Manual
[P] Stata Programming Reference Manual
[SEM] Stata Structural Equation Modeling Reference Manual
[SVY] Stata Survey Data Reference Manual
[ST] Stata Survival Analysis Reference Manual
[TS] Stata Time-Series Reference Manual
[TE] Stata Treatment-Effects Reference Manual:
Potential Outcomes/Counterfactual Outcomes
[I ] Stata Glossary and Index
[M] Mata Reference Manual
PDF manuals
Every copy of Stata comes with Stata’s complete PDF documentation.
The PDF documentation may be accessed from within Stata by selecting Help>PDF documentation.
Even more convenient, every help file in Stata links to the equivalent manual entry. If you are reading
help regress, simply click on [R] regress in the Title section of the help file to go directly to the
[R] regress manual entry.
We provide recommended settings for your PDF viewer to optimize it for Stata’s documentation at
http://www.stata.com/support/faqs/res/documentation.html.

Example datasets
Various examples in this manual use what is referred to as the automobile dataset, auto.dta. We
have created a dataset on the prices, mileages, weights, and other characteristics of 74 automobiles
and have saved it in a file called auto.dta. (These data originally came from the April 1979 issue
of Consumer Reports and from the United States Government EPA statistics on fuel consumption;
they were compiled and published by Chambers et al. [1983].)
In our examples, you will often see us type
. use http://www.stata-press.com/data/r14/auto
We include the auto.dta file with Stata. If you want to use it from your own computer rather than
via the Internet, you can type
. sysuse auto
See [D] sysuse.
You can also access auto.dta by selecting File > Example datasets..., clicking on Example
datasets installed with Stata, and clicking on use beside the auto.dta filename.
There are many other example datasets that ship with Stata or are available over the web. Here is
a partial list of the example datasets included with Stata:
auto.dta 		1978 Automobile Data
auto2.dta 		1978 Automobile Data
autornd.dta 		Subset of 1978 Automobile Data
bplong.dta 		fictional blood pressure data
bpwide.dta 		fictional blood pressure data
cancer.dta 		Patient Survival in Drug Trial
census.dta 		1980 Census data by state
citytemp.dta 		City Temperature Data
citytemp4.dta 		City Temperature Data
educ99gdp.dta 		Education and GDP
gnp96.dta 		U.S. GNP, 1967–2002
lifeexp.dta 		Life expectancy, 1998
network1.dta 		fictional network diagram data
network1a.dta 		fictional network diagram data
nlsw88.dta 		U.S. National Longitudinal Study of Young Women (NLSW, 1988 extract)
nlswide1.dta 		U.S. National Longitudinal Study of Young Women (NLSW, 1988 extract)
pop2000.dta 		U.S. Census, 2000, extract
sandstone.dta 		Subsea elevation of Lamont sandstone in an area of Ohio
sp500.dta		S&P 500
surface.dta 		NOAA Sea Surface Temperature
tsline1.dta 		simulated time-series data
tsline2.dta 		fictional data on calories consumed
uslifeexp.dta 		U.S. life expectancy, 1900–1999
uslifeexp2.dta 		U.S. life expectancy, 1900–1940
voter.dta 		1992 presidential voter data
xtline1.dta	 	fictional data on calories consumed
All of these datasets may be used or described from the Example datasets... menu listing.
Even more example datasets, including most of the datasets used in the reference manuals, are
available at the Stata Press website (http://www.stata-press.com/data/). You can download the datasets
with your browser, or you can use them directly from the Stata command line:
. use http://www.stata-press.com/data/r14/nlswork
An alternative to the use command for these example datasets is webuse. For example, typing
. webuse nlswork
is equivalent to the above use command. For more information, see [D] webuse.

A brief description of Stata
Stata is a statistical package for managing, analyzing, and graphing data.
Stata is available for a variety of platforms. Stata may be used either as a point-and-click application
or as a command-driven package.
Stata’s GUI provides an easy interface for those new to Stata and for experienced Stata users who
wish to execute a command that they seldom use.
The command language provides a fast way to communicate with Stata and to communicate more
complex ideas.
Here is an extract of a Stata session using the GUI:
(Throughout the Stata manuals, we will refer to various datasets. These datasets are all available from
http://www.stata-press.com/data/r14/. For easy access to them within Stata, type webuse dataset name,
or select File > Example datasets... and click on Stata 14 manual datasets.)
. webuse lbw
(Hosmer & Lemeshow data)
We select Data > Describe data > Summary statistics and choose to summarize variables low,
age, and smoke, whose names we obtained from the Variables window. We click on OK.

. summarize low age smoke
Variable 	Obs 	Mean	 Std. Dev. 		Min 	Max
low 	189 	.3121693 	.4646093 		0 	1
age 	189 	23.2381	 5.298678 		14 	45
smoke 	189 	.3915344 	.4893898 		0 	1
Stata shows us the command that we could have typed in command mode—summarize low age
smoke—before displaying the results of our request.
Next we fit a logistic regression model of low on age and smoke. We select Statistics > Binary
outcomes > Logistic regression (reporting odds ratios), fill in the fields, and click on OK.
. logistic low age smoke
Logistic regression Number of obs = 189
LR chi2(2) = 7.40
Prob > chi2 = 0.0248
Log likelihood = -113.63815 Pseudo R2 = 0.0315
low 	Odds Ratio 	Std. Err. 	z 	P>|z| 	[95% Conf. Interval]
age 	.9514394 	.0304194 	-1.56 	0.119 	.8936482 1.012968
smoke 	1.997405 	.642777 	2.15 	0.032 	1.063027 3.753081
_cons 	1.062798 	.8048781 	0.08 	0.936 	.2408901 4.689025

Here is an extract of a Stata session using the command language:
. use http://www.stata-press.com/data/r14/auto
(1978 Automobile Data)
. summarize mpg weight
Variable 	Obs 	Mean 	Std. Dev. 	Min 	Max
mpg 	74 	21.2973 	5.785503 	12 	41
weight 	74	 3019.459 	777.1936 	1760 	4840
The user typed summarize mpg weight and Stata responded with a table of summary statistics.
Other commands would produce different results:
. generate gp100m = 100/mpg
. label var gp100m "Gallons per 100 miles"
. format gp100m %5.2f
. correlate gp100m weight
(obs=74)
gp100m weight
gp100m 1.0000
weight 0.8544 1.0000
. regress gp100m weight gear_ratio
The user-interface model is type a little, get a little, etc., so that the user is always in control.
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Stata’s model for a dataset is that of a table—the rows are the observations and the columns are
the variables:
. list mpg weight gp100m  in 1/10
mpg 	weight 	gp100m
1. 22 	2,930 	4.55
2. 17 	3,350 	5.88
3. 22 	2,640 	4.55
4. 20 	3,250 	5.00
5. 15 	4,080 	6.67
6. 18 	3,670 	5.56
7. 26 	2,230 	3.85
8. 20 	3,280 	5.00
9. 16 	3,880 	6.25
10. 19 	3,400 	5.26
Observations are numbered; variables are named.
Stata is fast. That speed is due partly to careful programming, and partly because Stata keeps the
data in memory. Stata’s file model is that of a word processor: a dataset may exist on disk, but the
dataset in memory is a copy. Datasets are loaded into memory, where they are worked on, analyzed,
changed, and then perhaps stored back on disk.
Working on a copy of the data in memory makes Stata safe for interactive use. The only way to
harm the permanent copy of your data on disk is if you explicitly save over it.
Having the data in memory means that the dataset size is limited by the amount of computer
memory. Stata stores the data in memory in an efficient format—you will be surprised how much
data can fit. Nevertheless, if you work with extremely large datasets, you may run into memory
constraints. You will want to learn how to store your data as efficiently as possible; see [D] compress.

Resources for learning and using Stata
Overview
The Getting Started manual, User’s Guide, and Reference manuals are the primary tools for learning
about Stata; however, there are many other sources of information. A few are listed below.
_ Stata itself. Stata has a search command that makes it easy search a topic to find and to
execute a Stata command. See [U] 4 Stata’s help and search facilities.
_ The Stata website. Visit http://www.stata.com. Much of the site is dedicated to user support;
see [U] 3.2.1 The Stata website (www.stata.com).
_ The Stata YouTube Channel. Visit http://www.youtube.com/user/statacorp. The site is regularly
updated with video demonstrations of Stata.
_ The Stata Blog, Twitter, and Facebook. Visit http://blog.stata.com/, http://twitter.com/stata, and
http://facebook.com/statacorp. See [U] 3.2.3 The Stata Blog—Not Elsewhere Classified and
[U] 3.2.5 Stata on social media.
_ The Stata Press website. Visit http://www.stata-press.com. This site contains the datasets used
throughout the Stata manuals; see [U] 3.3 Stata Press.
_ The Stata forum. An active group of Stata users communicate over an Internet forum; see
[U] 3.2.4 The Stata forum.
_ The Stata Journal and the Stata Technical Bulletin. The Stata Journal contains reviewed papers,
regular columns, book reviews, and other material of interest to researchers applying statistics
in a variety of disciplines. The Stata Technical Bulletin, the predecessor to the Stata Journal,
contains articles and user-written commands. See [U] 3.4 The Stata Journal.
_ The Stata software distribution site and other user-provided software distribution sites. Stata
itself can download and install updates and additions. We provide official updates to Stata—type
update query or select Help > Check for updates. We also provide user-written additions to
Stata and links to other user-provided sites—type net or select Help > SJ and userwritten
commands; see [U] 3.5 Updating and adding features from the web.
_ NetCourses. We offer training via the Internet. Details are in [U] 3.6.2 NetCourses.
_ Public training courses. We offer in-depth training courses at third-party sites around the United
States. Details are in [U] 3.6.3 Public training courses.
_ On-site training courses. We can come to your institution to provide customized training. Details
are in [U] 3.6.4 Onsite
training courses.
_ Books and support materials. Supplementary Stata materials are available; see [U] 3.7 Books
and other support materials.
_ Technical support. We provide technical support by email, telephone, and fax; see [U] 3.8 Technical
support.
The Stata website (www.stata.com)
Point your browser to http://www.stata.com and click on Support. More than half our website is
dedicated to providing support to users.
_ The website provides answers to FAQs (frequently asked questions) on Windows, Mac, Unix,
statistics, programming, Internet capabilities, graphics, and data management. These FAQs run
the gamut from “I cannot save/open files” to “What does ‘completely determined’ mean in my
logistic regression output?” Most users will find something of interest.
_ The website provides detailed information about NetCourses, along with the current schedule;
see [U] 3.6.2 NetCourses.
_ The website provides information about Stata courses and meetings, both in the United States
and elsewhere. See [U] 3.6.1 Conferences and users group meetings, [U] 3.6.3 Public training
courses, and [U] 3.6.4 Onsite
training courses.
_ The website provides an online bookstore for Stata-related books and other supplementary
materials; see [U] 3.7 Books and other support materials.
_ The website provides links to information about statistics: other statistical software providers,
book publishers, statistical journals, statistical organizations, and statistical listservers.
_ The website provides links to resources for learning Stata at
http://www.stata.com/links/resources.html. Be sure to look at these materials, as many outstanding
resources about Stata are listed here.
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In short, the website provides up-to-date information on all support materials and, where possible,
provides the materials themselves. Visit http://www.stata.com if you can.
The Stata YouTube Channel
Visit Stata’s YouTube Channel at http://www.youtube.com/user/statacorp to view video demonstrations
on a wide variety of topics ranging from basic data management and graphics to more advanced
statistical analyses, such as ANOVA, regression, and SEM. New demonstrations are regularly added.
The Stata Blog—Not Elsewhere Classified
Stata’s official blog can be found at http://blog.stata.com/ and contains news and advice related
to the use of Stata. The articles appearing in the blog are individually signed and are written by the
same people who develop, support, and sell Stata.
The Stata Blog also has links to other blogs about Stata, written by Stata users around the world.
The Stata forum
Statalist is a forum dedicated to Stata, where thousands of Stata users discuss Stata and statistics.
It is run and moderated by Stata users and maintained by StataCorp. Statalist has a long history of
high-quality discussion dating back to 1994.
Many knowledgeable users are active on the forum, as are the StataCorp technical staff. Anyone
may join, and new-to-Stata members are welcome. Instructions for joining can be found at
http://www.statalist.org. Register and participate, or simply lurk and read the discussions.
Before posting a question to Statalist, you will want to read the Statalist FAQ, which can be found
at http://www.statalist.org/forums/help/.
Stata on social media
StataCorp has an official presence on Twitter, Facebook, Google+, and LinkedIn. You can
follow us on Twitter at http://twitter.com/stata. You find us on Facebook and Google+ at
http://facebook.com/statacorp and https://plus.google.com/s/statacorp. Connect with us on LinkedIn at
https://linkedin.com/company/statacorp. These are good ways to stay up-to-the-minute with the latest
Stata information.
Other Internet resources on Stata
Many other people have published information on the Internet about Stata such as tutorials, examples,
and datasets. Visit http://www.stata.com/links/ to explore other Stata and statistics resources on the
Internet.
Stata Press
Stata Press is the publishing arm of StataCorp LLC and publishes books, manuals, and journals
about Stata statistical software and about general statistics topics for professional researchers of all
disciplines.
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Point your browser to http://www.stata-press.com. This site is devoted to the publications and
activities of Stata Press.
_ Datasets that are used in the Stata Reference manuals and other books published by Stata
Press may be downloaded. Visit http://www.stata-press.com/data/. These datasets can be used
in Stata by simply typing use http://www.stata-press.com/data/r14/dataset name; for
example, type use http://www.stata-press.com/data/r14/auto. You could also type
webuse auto; see [D] webuse.
_ An online catalog of all our books and multimedia products is at
http://www.stata-press.com/catalog.html. We have tried to include enough information, such as
table of contents and preface material, so that you may tell whether the book is appropriate for
you.
_ Information about forthcoming publications is posted at
http://www.stata-press.com/forthcoming.html.
The Stata Journal
The Stata Journal (SJ) is a printed and electronic journal, published quarterly, containing articles
about statistics, data analysis, teaching methods, and effective use of Stata’s language. The Journal
publishes reviewed papers together with shorter notes and comments, regular columns, tips, book
reviews, and other material of interest to researchers applying statistics in a variety of disciplines.
The Journal is a publication for all Stata users, both novice and experienced, with different levels of
expertise in statistics, research design, data management, graphics, reporting of results, and in Stata,
in particular.
Tables of contents for past issues and abstracts of the articles are available at http://www.statajournal.
com/archives.html. PDF copies of articles published at least three years ago are available for
free from the Stata Journal website.
We recommend that all users subscribe to the SJ. Visit http://www.stata-journal.com to learn more
about the Stata Journal and to order your subscription.
To obtain any programs associated with articles in the SJ, type
. net from http://www.stata-journal.com/software
or
_ Select Help > SJ and userwritten
commands
_ Click on Stata Journal

How search works
search has a database—files—containing the titles, etc., of every entry in the User’s Guide,
Reference manuals, undocumented help files, NetCourses, Stata Press books, FAQs posted on the
Stata website, videos on StataCorp’s YouTube channel, selected articles on StataCorp’s official blog,
selected user-written FAQs and examples, and the articles in the Stata Journal and in the Stata Technical
Bulletin. In this file is a list of words associated with each entry, called keywords.
When you type search xyz, search reads this file and compares the list of keywords with xyz.
If it finds xyz in the list or a keyword that allows an abbreviation of xyz, it displays the entry.
When you type search xyz abc, search does the same thing but displays an entry only if it
contains both keywords. The order does not matter, so you can search linear regression or
search regression linear.
How many entries search finds depends on how the search database was constructed. We have
included a plethora of keywords under the theory that, for a given request, it is better to list too much
rather than risk listing nothing at all. Still, you are in the position of guessing the keywords. Do you
look up normality test, normality tests, or tests of normality? Normality test would be best, but all
would work. In general, use the singular and strike the unnecessary words. We provide guidelines
for specifying keywords in [U] 4.6 More on search above.

FAQ searches
To search across the FAQs, specify the faq option:
. search logistic regression, faq
(output omitted )
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Return codes
In addition to indexing the entries in the User’s Guide and all the Stata Reference manuals, search
also can be used to look up return codes.
To see information about return code 131, type
. search rc 131
[R] error messages . . . . . . . . . . . . . . . . . . . Return code 131
not possible with test;
You requested a test of a hypothesis that is nonlinear in the
variables. test tests only linear hypotheses. Use testnl.
To get a list of all Stata return codes, type
. search rc
(output omitted )
net search: Searching net resources
When you select Help > Search..., there are two types of searches to choose. The first, which
has been discussed in the previous sections, is to Search documentation and FAQs. The second is
to Search net resources. This feature of Stata searches resources over the Internet.
When you choose Search net resources in the search dialog box and enter keywords in the field,
Stata searches all user-written programs on the Internet, including user-written additions published in
the Stata Journal and the STB. The results are displayed in the Viewer, and you can click to go to
any of the matches found.
Equivalently, you can type net search keywords on the Stata command line to display the results
in the Results window. For the full syntax for using the net search command, see [R] net search.

More 
When you see more at the bottom of the screen,
Press : : : and Stata : : :
letter l or Enter displays the next line
letter q acts as if you pressed Break
Spacebar or any other key displays the next screen
Also, you can press the clear –more– condition button, the button labeled Go with a circle around it.
more is Stata’s way of telling you that it has something more to show you, but showing you
that something more will cause the information on the screen to scroll off.
set more off
If you type set more off, more conditions will never arise and Stata’s output will scroll by
at full speed.
If you type set more on, more conditions will be restored at the appropriate places.
Programmers: Do-file writers sometimes include set more off in their do-files because they do
not care to interactively watch the output. They want Stata to proceed at full speed because they plan
on making a log of the output that they will review later. Do-filers need not bother to set more on
at the conclusion of their do-file. Stata automatically restores the previous set more when the do-file
(or program) concludes.
Overview
With few exceptions, the basic Stata language syntax is

[bookmark: _Hlk515955507][by varlist:] command [varlist] [=exp] [if exp] [in range] [weight] [, options]

where square brackets distinguish optional qualifiers and options from required ones. In this diagram,
varlist denotes a list of variable names, command denotes a Stata command, exp denotes an algebraic
expression, range denotes an observation range, weight denotes a weighting expression, and options
denotes a list of options.
varlist
Most commands that take a subsequent varlist do not require that you explicitly type one. If no
varlist appears, these commands assume a varlist of all, the Stata shorthand for indicating all the
variables in the dataset. In commands that alter or destroy data, Stata requires that the varlist be
specified explicitly. See [U] 11.4 varlists for a complete description.
Some commands take a varname, rather than a varlist. A varname refers to exactly one variable.
The tabulate command requires a varname; see [R] tabulate oneway.
Example 1
The summarize command lists the mean, standard deviation, and range of the specified variables.
In [R] summarize, we see that the syntax diagram for summarize is

summarize [varlist] [=exp] [if exp] [in range] [weight] [, options]

Farther down on the manual page is a table summarizing options, but let’s focus on the syntax
diagram itself first. Because everything except the word summarize is enclosed in square brackets, the
simplest form of the command is “summarize”. Typing summarize without arguments is equivalent
to typing summarize all; all the variables in the dataset are summarized. Underlining denotes the
shortest allowed abbreviation, so we could have typed just su; see [U] 11.2 Abbreviation rules.


Abbreviation rules
Stata allows abbreviations. In this manual, we usually avoid abbreviating commands, variable
names, and options to ensure readability:
. summarize myvar, detail
Experienced Stata users, on the other hand, tend to abbreviate the same command as
. sum myv, d
As a general rule, command, option, and variable names may be abbreviated to the shortest string of
characters that uniquely identifies them.
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This rule is violated if the command or option does something that cannot easily be undone; the
command must then be spelled out in its entirety.
Also, a few common commands and options are allowed to have even shorter abbreviations than
the general rule would allow.
The general rule is applied, without exception, to variable names.
11.2.1 Command abbreviation
The shortest allowed abbreviation for a command or option can be determined by looking at the
command’s syntax diagram. This minimal abbreviation is shown by underlining:
regress
rename
replace
rotate
run
If there is no underlining, no abbreviation is allowed. For example, replace may not be abbreviated,
the underlying reason being that replace changes the data.
regress can be abbreviated reg, regr, regre, or regres, or it can be spelled out in its entirety.
Sometimes short abbreviations are also allowed. Commands that begin with the letter d include
decode, describe, destring, dir, discard, display, do, and drop, which suggests that
the shortest allowable abbreviation for describe is desc. However, because describe is such a
commonly used command, you may abbreviate it with the single letter d. You may also abbreviate
the list command with the single letter l.
The other exception to the general abbreviation rule is that commands that alter or destroy data
must be spelled out completely. Two commands that begin with the letter d, discard and drop, are
destructive in the sense that, once you give one of these commands, there is no way to undo the
result. Therefore, both must be spelled out.
The final exceptions to the general rule are commands implemented as ado-files. Such commands
may not be abbreviated. Ado-file commands are external, and their names correspond to the names
of disk files.
Option abbreviation
Option abbreviation follows the same logic as command abbreviation: you determine the minimum
acceptable abbreviation by examining the command’s syntax diagram. The syntax diagram for
summarize reads, in part,
summarize : : : , detail format
The detail option may be abbreviated d, de, det, : : : , detail. Similarly, option format may be
abbreviated f, fo, : : : , format.
The clear and replace options occur with many commands. The clear option indicates that
even though completing this command will result in the loss of all data in memory, and even though
the data in memory have changed since the data were last saved on disk, you want to continue. clear
must be spelled out, as in use newdata, clear.
The replace option indicates that it is okay to save over an existing dataset. If you type save
mydata and the file mydata.dta already exists, you will receive the message “file mydata.dta already
exists”, and Stata will refuse to overwrite it. To allow Stata to overwrite the dataset, you would type
save mydata, replace. replace may not be abbreviated.
Technical note
replace is a stronger modifier than clear and is one you should think about before using. With
a mistaken clear, you can lose hours of work, but with a mistaken replace, you can lose days of
work.
Variablename abbreviation
_ Variable names may be abbreviated to the shortest string of characters that uniquely identifies them
given the data currently loaded in memory.
If your dataset contained four variables, state, mrgrate, dvcrate, and dthrate, you could
refer to the variable dvcrate as dvcrat, dvcra, dvcr, dvc, or dv. You might type list dv to
list the data on dvcrate. You could not refer to the variable dvcrate as d, however, because
that abbreviation does not distinguish dvcrate from dthrate. If you were to type list d, Stata
would respond with the message “ambiguous abbreviation”. (If you wanted to refer to all variables
that started with the letter d, you could type list d*; see [U] 11.4 varlists.)
_ The character ~ may be used to mean that “zero or more characters go here”. For instance, r~8
might refer to the variable rep78, or rep1978, or repair1978, or just r8. (The ~ character is
similar to the * character in [U] 11.4 varlists, except that it adds the restriction “and only one
variable matches this specification”.)
Above, we said that you could abbreviate variables. You could type dvcr to refer to dvcrate,
but, if there were more than one variable that started with the letters dvcr, you would receive an
error. Typing dvcr is the same as typing dvcr~.



Data overview
Strings
A string is a sequence of characters.
Samuel Smith
California
U.K.
Usually—but not always—strings are enclosed in double quotes.
"Samuel Smith"
"California"
"U.K."
Strings typed in quotes are called string literals.
Strings can be stored in Stata datasets in string variables.
. use http://www.stata-press.com/data/r14/auto, clear
(1978 Automobile Data)
. describe make
variable name	 storage type 	display format 	value label 	variable label
make 		str18 		%-18s 				Make and Model
The string-variable storage types are str1, str2, : : : , str2045, and strL. For example, variable
make is a str18 variable. It can contain strings of up to 18 characters long. The strings are not all
str18 means that the variable cannot hold a string longer than 18 bytes, and even that is an unimportant
detail, because Stata automatically promotes str# variables to be longer when required.
. replace make = "Mercedes Benz Gullwing" in 1
variable make was str18 now str22
(1 real change made)
Strings in Stata can also be stored in labels and notes that let you see information about your
dataset. See [U] 12.6 Dataset, variable, and value labels and [U] 12.7 Notes attached to data.
Strings in Stata programs can be stored in string scalars, macros, characteristics, and in stored results.
Stata provides a suite of string functions, such as strlen(), substr().
. generate len = strlen(make)
. generate str first5 = substr(make, 1,5)
. list make len first5 in 1/2
make len first5
1. Mercedes Benz Gullwing 22 Merce
2. AMC Pacer 9 AMC P
Many Stata commands can use string variables.
. generate str brand = word(make, 1)
. tabulate brand
brand 		Freq. 	Percent 	Cum.
AMC 		2 	2.70 	2.70
Audi 		2 	2.70 	5.41
BMW 		1 	1.35 	6.76
Buick 		7 	9.46 	16.22
Cad. 		3 	4.05 	20.27
Chev. 		6 	8.11 	28.38
Datsun 		4 	5.41 	33.78
Dodge 		4 	5.41 	39.19
Fiat 		1 	1.35 	40.54
Ford 		2 	2.70 	43.24
Honda 		2 	2.70 	45.95
Linc. 		3 	4.05 	50.00
Mazda 		1 	1.35 	51.35
Merc. 		6 	8.11 	59.46
Mercedes 	1 	1.35 	60.81
Olds 		7 	9.46 	70.27
Peugeot 	1 	1.35 	71.62
Plym. 		5 	6.76 	78.38
Pont. 		6 	8.11 	86.49
Renault 	1 	1.35 	87.84
Subaru 		1 	1.35 	89.19
Toyota 		3 	4.05 	93.24
VW 		4 	5.41 	98.65
Volvo 		1 	1.35 	100.00
Total 		74 		100.00



Numeric formats
Stata has three numeric format types: e, f, and g. The formats are denoted by a leading percent
sign (%) followed by the string w.d, where w and d stand for two integers. The first integer, w,
specifies the width of the format. The second integer, d, specifies the number of digits that are to
follow the decimal point. d must be less than w. Finally, a character denotes the format type (e, f,
or g), and a c may optionally be appended to that to indicate that commas are to be included in the
result (c is not allowed with e.)
By default, every numeric variable is given a %w.0g format, where w is large enough to display
the largest number of the variable’s type. The %w.0g format is a set of formatting rules that present
the values in as readable a fashion as possible without sacrificing precision. The g format changes
the number of decimal places displayed whenever it improves the readability of the current value.
The default formats for each of the numeric variable types are
byte 	%8.0g
int 	%8.0g
long	 %12.0g
float	 %9.0g
double 	%10.0g
You can change the format of a variable by using the format varname % fmt command.
In addition to %w.0g, %w.0gc is also allowed and displays numbers with commas. “One thousand”
is displayed as 1000 in %9.0g format and as 1,000 in %9.0gc format.
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Opening a Stata Formatted Data File (has a “.dta” file extension).

There are three ways to open a Stata data file.

First way:  
Using Windows Explorer, shown as a file folder, “My Documents” or “Documents” icon on your desktop), find the directory that the data file exists in.   The directory path will look something like:

	C:\Users\Greg\Desktop\Biostats 

It is a good habit to use the Data Browser, rather than the Data Editor, since you might accidently modify your data in the Data Editor.  The Data Browser only permits you to look at the data without making changes. 


Second way:  

To practice with the next way to read in a Stata file, first exit Stata.  
Execute the Stata Program, by clicking on its icon on the desktop.  Notice that in the lower left corner, the working directory is “C:\DATA”, if you are using Stata version 10 or earlier.  It is something like “C:\Users\Greg\Documents” if you using Stata version 12.  This is the default directory for storing data files unless you change directories yourself.  We don’t want that directory because the data file is not in it.  

	. "C:\Users\Greg\Desktop\Biostats\births_with_missing.dta", clear	
		
The “.” is Stata informing you this output is the command that was executed.  The “>” is Stata informing you the command was “wrapped around” in the Results window because it was too long to display on one line.

What Stata did was execute its use command and specifying both the directory path and file name.  Notice, however, it did not change the working directory, which is still set to the default directory .

Third way:  
This time we will use the Stata Command window, with the following four commands in the Command window, entered and executed one at a time,

	clear all
cd "C:\Users\Greg\Desktop\Biostats
dir 
use births_with_missing, clear


    
The first command, “clear”, clears the workspace.  We must clear the Stata workspace if data are there, since Stata will not let us read data over the top of what data are already in the workspace.  The “all” option is usually not needed.  However, if you ever get an error message informing you something cannot be cleared, such as matrices that Stata sometimes creates behind the scenes, the “clear all” command is just what you need in that situation.

The second command, cd, which stands for “change directory” changes the working directory to the directory where the data file exits.  We include the directory path in quotes, in this example, since there are embedded spaces, which will otherwise confuse Stata. It is easiest to cut-and-and paste the directory path from Windows Explorer.  If the directory path is very long, you can break it up into two more lines, like the following example shows, where you change the directory part way through the path on each line.
    
The third command, dir, which stands for “directory list”, tells us all of the files in the directory we changed to.  This is not needed, but it can be useful in the situation where you want to cut-and-paste a file name from the Result window to build the use command.

The fourth command reads in the data, where use stands for “use a Stata formatted file”.   The option, clear, does the same thing as the clear command, so it is not needed and was redundant in this example.  You will frequently find it is easier to use clear as an option, rather than having to do it on a separate line, so the option was introduced here.

Using Do-Files
In real life, you should always perform your data cleaning and data analysis commands in a do-file.  This will save you a lot of work, as well as document what you did.  The do-file editor allows you to cut-and-paste commands, as you will do similar things for your many variables.  It also lets you recreate your entire data cleaning and analysis process by a click of a button, which you will need to do if you add some more subjects to your data file, for example. 
After opening Stata, you call up the do-file editor by clicking on the icon on the menu bar that looks like a notebook (fifth icon from the right).  

Suggested Do-File Structure
I suggest you set up you do-file for every study using the following structure.
1) at top, identify which study it is for and the file name of the do-file
2) next, have a section for reading in your original data file, set up your variables (the gen’s, replace’s, recode’s, etc.) and then save the data out to a new file
3) next, have a section for analyzing your data, which begins by reading in the new file

With this approach, you never have to worry about making a mistake because you know you can re-create the data simply by highlighting the top section and re-running it.

In the bottom portion, you know you have clean dataset to work with, so you just pick-and-choose commands to re-run, or cut-and-paste and then modify.  Your entire data analysis could be re-created by re-running this section.

Beginning with version 12, the “set mem”, or set memory command is no longer needed.  Now Stata dynamically adjusts the available memory it requires without the user having to do anything.  

The following suggested do-file structure does not include the “set mem”line.

	* file:  Ch 1-2.do
* Stata programming class

*----------------- begin set up variables ---------------
clear all
cd "C:\Documents and Settings\u0032770.SRVR\Desktop\"
cd "Biostats\datasets & do-files"
insheet using births_messy_Ch2.csv, clear

save births_messy_Ch2, replace
*------------------ end set up variables -----------------


*------------------ begin data analysis ------------------
clear all
cd "C:\Documents and Settings\u0032770.SRVR\Desktop\"
cd "Biostats & Epi With Stata\datasets & do-files"
use births_messy_Ch2, clear


    


Importing an Excel File Into Stata (Stata Version 12 or higher)

This time we will read from an Excel file called births_messy_Ch2.xls.  Beginning with version 12, Stata can import directly from an Excel file.  

You must begin from inside Stata, so first open Stata by double clicking its icon.  

If you look in the lower left corner of the Stata window, you will see the default data directory, something like “C:\Users\Greg\Documents”.  That is not where the data file is.  So, we must first use the “change directory”, cd,  command to provide Stata with the directory path.  It will look somewhat different for everyone’s computer, but will appear somewhat similar.  We include the directory path in quotes since there are embedded spaces, which will otherwise confuse Stata.

	cd "C:\Users\Greg\Desktop\Biostats\datasets & do-files"


    
Notice we do not include the name of the file in this command, since the file name is not part of the directory path.  You will, of course, have to change this directory path to match what’s on your computer.

One way to do this is to cut-and-paste the directory path from the address bar in Windows Explorer or the Documents folder.

Another way is to use the Stata menu, which does not require first using the change directory command. To read the file in, we use the import command.  

Doing this with the Stata menu,

	File
    Import
        Excel spreadsheet (*.xls; *.xlsx)
             Excel file:  Browse to find the directory where you copied the course CD and  
             find the subdirectory datasets & do-files:  births_messy_Ch2
                Worksheet:  change to a different worksheet if needed
                     OK



If data are already in memory, you will get a window asking, “Data in memory have changed since last save.  Do you want to continue and lose unsaved data?”  Clicking on Yes will add the clear option to the import command it is constructing,

   . import excel "C:\Users\Greg\Desktop\Biostats \datasets 
   > & do-files\births_messy_Ch2.xls", sheet("Sheet1") clear

Doing this with a command, after having used the change directory, cd, command,

	import excel "births_messy_Ch2.xls", sheet("Sheet1")



or, if data already exist in the Stata workspace, then combine the import and clear commands by using clear as an option,

	import excel "births_messy_Ch2.xls", sheet("Sheet1") clear



You will notice that by default Stata uses the first row in the spreadsheet as data.  So, it assigns the Excel column names to the variable, A, B, C, etc.
	
Usually, you have variable names in the first row of the spreadsheet. 

Importing the data, with the first row being treated as variable names, using the Stata menu,

	File
    Import
        Excel spreadsheet (*.xls; *.xlsx)
             Excel file:  Browse to find the directory where you copied the course CD and  
             find the subdirectory datasets & do-files:  births_messy_Ch2
                Worksheet:  change to a different worksheet if needed
                    Check the option: Import first row as variable names
                        OK



   . import excel "C:\Users\Greg\Desktop\Biostats\datasets 
   > & do-files\births_messy_Ch2.xls", sheet("Sheet1") clear firstrow 

Doing this with a command, after having used the change directory, cd, command,

	import excel "births_messy_Ch2.xls", sheet("Sheet1") clear firstrow



Now Stata will use the first row in the Spreadsheet as variable names.  If a cell is blank in the first row, the Excel column name will be used for that particular variable name.


The third way of getting data into Stata is to save it first in csv format and use insheet command. Assuming your file is called mystudy.csv,

	* file:  Ch 1-2.do
* Stata programming class

*----------------- begin set up variables ---------------
clear
set mem 10m   // increase Stata workspace to 10 megabytes
cd "C:\Documents and Settings\u0032770.SRVR\Desktop\"
cd "Biostats & Epi With Stata\datasets & do-files"
insheet using mystudy.csv


    

Saving data as a Stata formatted file,  (.dta) file name extension

Having done all this work to get the data in, let’s save it as a Stata formatted data file so we can read it easier next time,

	save births_messy_Ch2     



which saves the file as births_messy_Ch2.dta, where “.dta” is Stata’s data file extension.
Or, if you want to overwrite an existing file,

	save births_messy_Ch2, replace    




